Monthlyalltime.ini

From CumulusWiki
Jump to: navigation, search

The file monthlyalltime.ini was introduced in version 1.9.3 to support the Monthly Records (i.e. the extremes recorded in all January periods, all February periods etc). For more information on this file see in the Cumulus help file, in the section “Data log file format”.

Initialisation

If you were using Cumulus prior to installing version 1.9.3 then you need to initialise log file by reading prior data from the monthly and daily log files. Follow the instructions for correcting the file. Once the file has been initialised, Cumulus will maintain it from then onwards, comparing the highs and lows for the current reading against those stored for that month in this file. For further information see the support forum, that contains the announcement when version 1.9.3 was released, and a few discussions concerning experience with the feature.

Viewing the monthly highs and lows

Cumulus View menu.jpg Select Highs and Lows - Monthly from View menu.

Correcting the file within Cumulus

Expanding the information in the FAQ: FAQ#How_do_I_correct_my_all-time_.28or_monthly.29_records.3F, you can update the values stored in monthlyalltime.ini by choosing all time monthly records from the Edit menu in Cumulus. This is a text editor, and works best when at full screen. By clicking the appropriate buttons, you can get Cumulus to display the extremes found by looking through all the data available in dayfile.txt for the selected month in all years, and all the data available in Monthly log files for that month in all years. Click the Help button on that screen for detailed instructions on how to copy figures across from log to log or to directly edit them on screen.

Editing monthlyalltime.ini outside Cumulus

It is unlikely that you need to do this, given the functionality of the in-built editor. Cumulus MX however, does not yet have an editor, so you have no choice but to edit the file manually. If you cannot find the file see FAQ FAQ#I_can.E2.80.99t_find_my_data_files.21.

Tips -- take a copy of the original log file before you work on it outside Cumulus.

Stop Cumulus first. Edit the original file using an editor that treats all fields as text [either any text editor, or a spreadsheet program that can be instructed not to recognise special field (like date) types]. Do not add nor remove parameters, simply amend the values and timestamps. Note that figures are held internally in Cumulus in binary, and converted to Base 10 numbers for the value shown. Since fractional binary values cannot be converted exactly to base 10 decimals, real numbers appear to be given to a strange decimal resolution with multiple decimal places. Also note that the timestamp includes a calendar date, so for a 9 or 10am rollover, if you need to manually look for highs and lows for times between midnight and rollover, these would be derived from the daily log (dayfile.txt) row for the meteorological date (the date before the calendar date for those early hours).

The format of monthlyalltime.ini is similar to alltime.ini but the sections are repeated for each month of the year, distinguished by a two-digit number at the end of the section name, representing the month for that section. For example, the rainfall records for September are held in section [Rain09].